Most popular 

Sntp

software
NetTime
free rating
11,458
Mark Griffiths
If the accuracy of your system time is of the essence for you or you work...
Simple Network Time Protocol (SNTP) to update
Dimension 4
free rating
2,358
Thinking Man Software
It is the fastest and easiest way to synchronize your computer's clock if you're running...
level Internet protocol, called SNTP, to connect...of the most popular SNTP time servers
Absolute Time Server
rating
1,378
FlexibleSoft Co.
Absolute Time Server is a full-fledged time server capable of running...
Absolute Time Server is a full-fledged time server capable of running as a Windows service
SP TimeSync
rating
584
Alexander Panchenko
SP TimeSync is a program with multilingual interface which lets you synchronize...
SP TimeSync is a program with multilingual interface which lets you synchronize your computer's
UTime
free rating
577
iceelyne
U(niversal).Time is a multi-protocol network time client, written in C#...
NET / Mono. U.Time supports SNTP (RFC2030) / Time (RFC868) /
PerfectClock
rating
563
ALSEDI Group
One desktop application that lets you choose from a wide variety of clock designs...
the time with other SNTP servers. I enjoy the fact
Advanced Time Synchronizer
rating
528
Southsoftware.com
This is a general-purpose and light weight computer time synchronizer...
Advanced Time Synchronizer is a PC clock synchronizer. It works
Atomic Time Synchronizer
rating
327
LmhSoft
Atomic Time Synchronizer periodically checks and synchronizes your computer clock with NIST atomic time servers...
Atomic Time Synchronizer periodically checks and synchronizes your computer clock with NIST atomic
AboutTime
free rating
210
Paul Lutus
About Time acts as a time server and a client for your system...
servers using the popular SNTP protocol. It automatically...various protocols such as SNTP, TCP etc
Net Time Server & Client
rating
202
Han-soft Corporation
The time synchronization application synchronize your PC's system clock or all PC's system clock in your LAN using...
Time Protocol(SNTP-RFC2030, SNTP-RFC4330) ...Time Protocol(SNTP-RFC2030, SNTP-RFC4330)
PC Atomic Sync
rating
68
Brigsoft
If you want to always have the exact time on your PC's clock, this program will do the job. It synchronizes...
If you are one of those people that are obsessed about having the exact time on their clocks
Chronos Clock
rating
67
Rainbow Innovations
It is is a desktop clock capable of displaying multiple international clocks...
It is is a desktop clock capable of displaying multiple international clocks and timers
TimeTools SNtp Time Client
free rating
40
TimeTools
TimeTools provides highly accurate GPS NTP Server and atomic clock timing systems and solutions for PC's and computer...
TimeTools provides highly accurate GPS NTP Server and atomic clock timing
YATS32
rating
29
Dillobits Software, Inc.
Eliminate your problems with drifting and inaccurate system time. Never manually adjust your computer clock again...
time service protocols, including SNTP, TIME and Unix
TWAtomTime
rating
24
Thomas Wenzlaff
Time syncron with timserver ntp
Time syncron with timserver ntp
Advanced Network Monitor
rating
24
URL Toy Software
Advanced Network Monitor 2.3 is a tool that monitors servers located on your local network...
check, NetBIOS, SNMP, LDAP, SNTP, Oracle, MSSQL, Interbase, ODBC
iTimeSync
rating
5
ACAPsoft
iTimeSync synchronizes your computer clock with an internet time server. It supports both RFC-868 (TIME) and RFC-2030 (SNTP)...
) and the RFC-2030 (SNTP) protocols. Additionally, iTimeSync can
AtomiT
free rating
5
FLAzH
AtomiT is a Atomic time software for your Personal Computer DAYTIME, the daytime protocol (RFC-867)...
on UDP port 123. SNTP formats are compatible
#1 Atomic Clock
rating
1
freefileszone.com
Atomic Clock synchronizing application with some useful options (skinned, synchronize periods...
Atomic Clock lets you synchronize your computer's clock with any Internet atomic clock
Atomic Clock Service
rating
1
Brigsoft
PC atomic clock synchronizer with some useful features (time offset, synchronize periods, etc.)...
It is an Internet PC atomic clock synchronizing application with some useful options

Tags

Time Clock Synchronize Internet Ntp Synchronization Time server Nist Atomic Program